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How to update an expired XMETA user password? - Datastage Director message: "Failed to authenticate the current user against the selected Services Tier"

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TitleHow to update an expired XMETA user password? - Datastage Director message: "Failed to authenticate the current user against the selected Services Tier"
SummaryWhen trying to login to the Director Datastage it throws an error "Failed to authenticate the current user against the selected Services Tier"
URL NameDatastage-Password-and-Oracle-access
Resolution
log into xmeta db via sqlplus and renew password. (following the prompts)

On cmd prompt type e.g. "sqlplus xmeta/xmeta@tns" and follow the prompts to set password to i.e. xmeta



 
ProductsCategory Knowledge Base
ModuleJDA Integrator
Version8.0
Error Message Code
Datastage Director:
"
Failed to authenticate the current user against the selected Services Tier
Could not connect to server [host.domain.com] on port [9080].
Error message:
Failed to authenticate the current user against the selected Services Tier
"

SystemErr.log:
"[IBM][Oracle JDBC Driver][Oracle]ORA-28001: the password has expired"
 
Cause
This error may occur if the Oracle xmeta schema password has expired.
Additional Information
Error message in context:

Datastage Director:
(on login attempt using default credentials: isadmin/isadmin)
Failed to authenticate the current user against the selected Services Tier
Could not connect to server [host.domain.com] on port [9080].
Error message:
Failed to authenticate the current user against the selected Services Tier

Exception type: javax/security/auth/login/LoginException
Exception message: Could not connect to server [host.domain.com] on port [9080].
Exception stack trace:
javax.security.auth.login.LoginException: Could not connect to server [host.domain.com] on port [9080].
    at com.ascential.acs.security.auth.client.AuthenticationService.getLoginException(AuthenticationService.java:978)
    at com.ascential.acs.security.auth.client.AuthenticationService.doLogin(AuthenticationService.java:355)
Caused by: com.ascential.acs.registration.client.RegistrationContextManagerException: Caught an unexpected exception.



SystemErr.log: (in e.g. C:\IBM\WebSphere\AppServer\profiles\InfoSphere\logs\server1)
[IBM][Oracle JDBC Driver][Oracle]ORA-28001: the password has expired
...
user=xmeta



Other:
Also consider reviewing password life for all users.

See also:
http://www-01.ibm.com/support/docview.wss?uid=swg21973983

or general Oracle related articles "around" the following key expressions:
  • ALTER USER xmeta IDENTIFIED BY xmeta;
  • ALTER USER user_name ACCOUNT UNLOCK;
  • ALTER PROFILE DEFAULT LIMIT PASSWORD_LIFE_TIME UNLIMITED;
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